<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11" />
	<title>Apple iPhone 12 series release date &amp; specs - what we know so far</title>
<link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin><meta property="og:site_name" content="Inferse" /><meta property="og:title" content="Apple iPhone 12 series release date &amp; specs - what we know so far" /><meta property="og:type" content="article" /><meta property="og:description" content="The iPhone 12 may not be forthcoming till at least fall of this year though that isn&#039;t stopping the Apple phone from making waves already. The iPhone 12 seem to..." /><meta property="og:url" content="https://www.inferse.com/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/" /><meta property="og:image" content="https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-1000x637.jpg" /><meta property="og:image:url" content="https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-1000x637.jpg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:site" content="@" /><meta name="twitter:title" content="Apple iPhone 12 series release date &amp; specs - what we know so far" /><meta name="twitter:description" content="The iPhone 12 may not be forthcoming till at least fall of this year though that isn&#039;t stopping the Apple phone from making waves already. The iPhone 12 seem to..." /><meta name="twitter:url" content="https://www.inferse.com/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/" /><meta name="twitter:image" content="https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-1000x637.jpg" /><meta name="author" content="Sovan Mandal">

<!-- This site is optimized with the Yoast SEO Premium plugin v13.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.inferse.com/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/" />
<!-- / Yoast SEO Premium plugin. -->

<link rel="amphtml" href="https://www.inferse.com/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/amp/" /><meta name="generator" content="AMP for WP 1.0.49"/><link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Inferse &raquo; Feed" href="https://www.inferse.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Inferse &raquo; Comments Feed" href="https://www.inferse.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Inferse &raquo; Apple iPhone 12 series release date &#038; specs &#8211; what we know so far Comments Feed" href="https://www.inferse.com/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.inferse.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.inferse.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://www.inferse.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://www.inferse.com/wp-content/themes/bone/vendors/bootstrap/bootstrap.css?ver=3.3.4' type='text/css' media='all' />
<link rel='stylesheet' id='fotorama-css'  href='https://www.inferse.com/wp-content/themes/bone/vendors/fotorama/fotorama.css?ver=4.6.4' type='text/css' media='all' />
<link rel='stylesheet' id='owl-carousel-css'  href='https://www.inferse.com/wp-content/themes/bone/vendors/owl-carousel/owl.carousel.min.css?ver=2.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='zoom-js-css'  href='https://www.inferse.com/wp-content/themes/bone/vendors/zoom/zoom.css?ver=0.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='md-bone-style-css'  href='https://www.inferse.com/wp-content/themes/bone/style.css?ver=2.4.0' type='text/css' media='all' />
<style id='md-bone-style-inline-css' type='text/css'>
.fotorama__thumb-border,.tagcloud a:hover,.postTags-list > a:hover,.postVia-list > a:hover,.postSource-list > a:hover,.tabs-nav li.active a:after,.navigation--standard > ul > li > a:before,.articleTags-list > a:hover,input[type="submit"],input[type="submit"]:hover{border-color:#1976d2;}.reviewMeter-item-score:after,.commentCountBox:after{border-top-color:#1976d2;}
</style>
<link rel='stylesheet' id='font-awesome-css'  href='https://www.inferse.com/wp-content/themes/bone/vendors/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.inferse.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-38987202-1' async></script>
<script type='text/javascript'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-38987202-1', {"anonymize_ip":true} );
</script>
<link rel='https://api.w.org/' href='https://www.inferse.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.inferse.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.inferse.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://www.inferse.com/?p=56881' />
<link rel="alternate" type="application/json+oembed" href="https://www.inferse.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.inferse.com%2F56881%2Fapple-iphone-12-series-release-date-specs-what-we-know-so-far%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.inferse.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.inferse.com%2F56881%2Fapple-iphone-12-series-release-date-specs-what-we-know-so-far%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.8.0" /><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>
(adsbygoogle = window.adsbygoogle || []).push({
google_ad_client: "ca-pub-6185183459139085",
enable_page_level_ads: true,
tag_partner: "site_kit"
});
</script>
		
<!-- Schema & Structured Data For WP v1.9.36 - -->
<script type="application/ld+json" class="saswp-schema-markup-output">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</script>

<link rel="icon" href="https://www.inferse.com/wp-content/uploads/2020/04/inferse-favicon-100x100.png" sizes="32x32" />
<link rel="icon" href="https://www.inferse.com/wp-content/uploads/2020/04/inferse-favicon-300x300.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.inferse.com/wp-content/uploads/2020/04/inferse-favicon-300x300.png" />
<meta name="msapplication-TileImage" content="https://www.inferse.com/wp-content/uploads/2020/04/inferse-favicon-300x300.png" />
<style type="text/css" title="dynamic-css" class="options-output">.siteTitle--default{padding-top:0;padding-right:0;padding-bottom:0;padding-left:0;}.siteTitle--small{padding-top:0px;padding-right:0;padding-bottom:0px;padding-left:0;}.primaryBgColor,input[type="submit"],.postCategory,.progressContainer-bar,.reviewMeter-item-score,.reviewBox-summary-totalScore-wrap,.postTitle .featuredBadge,.btn.btn--solid,.btn.btn--solid:active,.btn.btn--solid:focus,.btn.btn--solid:hover,.btn.btn--solid:visited,.postFormatLink .o-backgroundImg,.featuredBlock--slider article.noThumb,.post--review-meter-bar,.post--review-score, .post--tile.noThumb,.commentCountBox,.byCategoryListing-title i,.categoryTile .o-backgroundImg,.mdPostsListWidget .list-index,.widget_archive li:hover:after,.widget_calendar caption,.widget_calendar #today,.wp-block-calendar table caption,.wp-block-calendar #today,.block-title span:after,.widget_mc4wp_form_widget input[type="submit"],.wpp-list-with-thumbnails > li:hover > a:first-child:after,.md-pagination .page-numbers.current,.offCanvasClose,.siteFooter-top-wrap{background-color:#1976d2;}.primaryColor, .primaryColor:hover, .primaryColor:focus, .primaryColor:active, .authorName, .authorName a, .articleMeta-author a, .siteLogo-name,.articleTags-list > a:hover,.articleVia-list > a:hover,.articleSource-list > a:hover,.comment-author:hover,.post--card--bg.noThumb .postInfo .postMeta--author-author a,.loginFormWrapper .modal-close i,.postTitle .postFormatBadge,.widget_pages ul.children > li:before,.widget_categories ul.children > li:before,.widget_nav_menu .submenu-toggle,.widget_calendar td a,.wp-block-calendar td a,.tagcloud a:hover,.postTags-list > a:hover,.postVia-list > a:hover,.postSource-list > a:hover,.widget_recent_comments .comment-author-link,.widget_recent_comments .comment-author-link a,.tabs-nav li.active a,.widget_pages li > a:before,.wpp-list:not(.wpp-list-with-thumbnails) > li:hover:before,.postFormatBadge,.comment-author, .postMeta--author-author a,.postFormatQuote:before,.logged-in-as a:first-child{color:#1976d2;}.titleFont,.postTitle,h1,h2,h3,h4,h5,h6,.widget_recent_comments .comment-author-link,.widget_recent_comments li > a,.widget_recent_entries a,.widget_rss a.rsswidget,.widget_rss .rss-date,.wpp-post-title{font-family:Poppins,Arial, Helvetica, sans-serif;}body, .bodyCopy{font-family:Arial, Helvetica, sans-serif,Georgia, serif;}label,input[type=submit],.metaText,.metaFont,.metaBtn,.postMeta,.postCategory,.blockHeading,.comment-reply-title,.wp-caption,.gallery-caption,.widget-title,.btn,.navigation,.logged-in-as,.widget_calendar table,.wp-block-calendar table,.tagcloud a,.widget_nav_menu .menu,.widget_categories li,.widget_meta li > a,.widget_pages li,.widget_archive a,.comment-reply-title small,.wpp-meta,.wpp-list-with-thumbnails > li > a:first-child:after,.wpp-list:not(.wpp-list-with-thumbnails) > li:before{font-family:'Arial Black', Gadget, sans-serif,Arial, Helvetica, sans-serif;}.featuredBlockBackground{background-color:transparent;}</style></head>

<body class="post-template-default single single-post postid-56881 single-format-standard wp-embed-responsive">
		
	<!-- siteWrap -->
	<div class="siteWrap">
		
		<!-- siteHeader -->
		<header class="siteHeader siteHeader--compact">

			<div class="siteHeader-nav js-searchOuter">
				<div class="container">
					<div class="flexbox">
						<div class="siteHeader-component--left flexbox-item">
							<div class="menuToggleBtn js-menu-toggle btn btn--circle hidden-sm hidden-md hidden-lg"><i class="fa fa-navicon"></i></div>
							<div class="menuToggleBtn js-menu-toggle btn btn--pill hidden-xs hidden-md hidden-lg"><i class="fa fa-navicon"></i><span>Menu</span></div>
							<div class="siteTitle siteTitle--default siteTitle--compact hidden-xs hidden-sm metaFont">
								<a class="siteLogo siteLogo--image" href="https://www.inferse.com/" title="Inferse" rel="home">
		<img src="https://www.inferse.com/wp-content/uploads/2016/01/inf-editors-pick-logo.png" width="150" height="40" data-hidpi="https://www.inferse.com/wp-content/uploads/2015/04/logo-retina.png" rel="logo" alt="Inferse" style="max-height:65px;">
	</a>
							</div>

							<nav class="navigation navigation--main navigation--standard hidden-xs hidden-sm">
								<ul id="menu-main-menu" class="menu"><li id="menu-item-56788" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56788"><a href="https://www.inferse.com/news/">News</a></li>
<li id="menu-item-56790" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56790"><a href="https://www.inferse.com/smartphones/">Smartphones</a></li>
<li id="menu-item-56784" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56784"><a href="https://www.inferse.com/business/">Business</a></li>
<li id="menu-item-56786" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56786"><a href="https://www.inferse.com/gaming/">Gaming</a></li>
<li id="menu-item-56789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56789"><a href="https://www.inferse.com/science/">Science</a></li>
<li id="menu-item-56787" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56787"><a href="https://www.inferse.com/how-to/">How To</a></li>
<li id="menu-item-56785" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56785"><a href="https://www.inferse.com/editorials/">Editorials</a></li>
</ul>							</nav>
						</div>

						<div class="siteHeader-component--center flexbox-item hidden-md hidden-lg">
							<div class="siteTitle siteTitle--small siteTitle--compact metaFont">
								<a class="siteLogo siteLogo--image" href="https://www.inferse.com/" title="Inferse" rel="home">
				<img src="https://www.inferse.com/wp-content/uploads/2016/01/inf-editors-pick-logo.png" width="150" height="40" data-hidpi="https://www.inferse.com/wp-content/uploads/2015/04/logo-retina.png" rel="logo" alt="Inferse" style="max-height:65px;">
			</a>

							</div>
						</div>

						<div class="siteHeader-component--right headerActions flexbox-item">
							<div class="compactSearch">
								<div class="searchToggleBtn btn btn--circle js-searchToggle hidden-sm"><i class="fa fa-search iconSearch"></i><i class="fa fa-times iconClose"></i></div>
								<div class="searchToggleBtn btn btn--pill js-searchToggle hidden-xs hidden-md hidden-lg"><i class="fa fa-search iconSearch"></i><i class="fa fa-times iconClose"></i><span>Search</span></div>
								<div class="searchField metaFont">
	<form class="searchField-form" method="get" action="https://www.inferse.com/">
		<input type="text" name="s" class="searchField-form-input" placeholder="Search..." value="">
		<button type="submit" class="searchField-form-btn"><i class="fa fa-search"></i></button>
	</form>
</div>							</div>
							
													</div><!-- end headerActions -->
					</div>
				</div>
			</div><!-- end siteHeader-nav -->
			
			
		</header>
		<!-- end siteHeader -->
<main class="layoutBody">
	<div class="container">
		<div class="layoutContent clearfix">

			<div class="layoutContent-main hasRightSidebar">				
					
				<article class="postSingle postSingle--cover hentry post-56881 post type-post status-publish format-standard has-post-thumbnail category-smartphones tag-apple tag-iphone">
								<script type="application/ld+json">
				{
					"@context": "http://schema.org/",
					"@type": "BlogPosting",
					"mainEntityOfPage": {
						"@type": "WebPage",
						"@id": "https://www.inferse.com/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/"
					},
					"headline": "Apple iPhone 12 series release date &#038; specs &#8211; what we know so far",
					"image": [
						"https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-400x255.jpg"
					],
					"datePublished": "2020-05-18T10:44:25-04:00",
					"dateModified": "2020-05-18T10:44:25-04:00",
					"author": {
						"@type": "Person",
						"name": "Sovan Mandal"
					},
					"publisher": {
						"@type": "Organization",
						"name": "Inferse",
						"logo": {
							"@type": "ImageObject",
							"url": "https://www.inferse.com/wp-content/uploads/2016/01/inf-editors-pick-logo.png"
						}
					},
					"description": "The iPhone 12 may not be forthcoming till at least fall of this year though that isn&#8217;t stopping the Apple phone from making waves already. The iPhone 12 seem to be hitting the headlines with alarming regularity revealing key aspects of the phone in the process. Mentioned here is a compilation of all that we [&hellip;]"
				}
			</script>
										<div class="postSingle-cover">
			<div class="o-backgroundImg o-backgroundImg--dimmed"  style="background-image: url(https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-1000x637.jpg);"></div>
			<div class="postInfo overlayInfo">
				<div class="postSingle-header">
					<ul class="postCategories list-inline"><li><a class="postCategory" href="https://www.inferse.com/smartphones/" title="View all posts in Smartphones" rel="tag">Smartphones</a></li></ul>					<h1 class="postTitle entry-title">Apple iPhone 12 series release date &#038; specs &#8211; what we know so far</h1>
									<div class="postMeta postMeta--3 flexbox">
					<div class="flexbox-item">
								<div class="postMeta--author postMeta--author--4 o-media vcard author">
			<div class="postMeta--author-avatar o-media-left o-media--middle photo"><img alt='avatar' src='https://secure.gravatar.com/avatar/8333194bfcc3a7369469384a0c5914bd?s=32&#038;r=g' srcset='https://secure.gravatar.com/avatar/8333194bfcc3a7369469384a0c5914bd?s=64&#038;r=g 2x' class='avatar avatar-32 photo' height='32' width='32' /></div>
			<div class="postMeta--author-text o-media-body o-media--middle">
				<span class="metaText--sub">by</span>
				<div class="postMeta--author-author metaFont fn">
					<a href="https://www.inferse.com/author/iamsovy/" title="Posts by Sovan Mandal" rel="author">Sovan Mandal</a>				</div>
			</div>
		</div>
							</div>
					<div class="flexbox-item">
						<div>
							<span class="metaText--sub">posted on</span>
							<div class="metaFont metaDate"><abbr class="published updated" title="May 18, 2020">May 18, 2020</abbr></div>	
						</div>
					</div>
					<div class="flexbox-item">
												<a href="https://www.inferse.com/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/#respond" title="Comment" class="metaFont commentCountBox">
							0						</a>
					</div>
				</div>
							</div>
			</div>
		</div>
						
					
						<div class="postContent bodyCopy clearfix">
							
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="59195061b77030439e3535e96025da7a" data-index="1" style="float: none; margin:0px 0 0px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Inferse Post Starting -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6185183459139085"
     data-ad-slot="1025061420"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p>The iPhone 12 may not be forthcoming till at least fall of this year though that isn&#8217;t stopping the Apple phone from making waves already. The iPhone 12 seem to be hitting the headlines with alarming regularity revealing key aspects of the phone in the process.</p>
<p>Mentioned here is a compilation of all that we know of the next generation iPhone coming our way.</p>
<p><strong>Four new models: </strong></p>
<p>The new iPhone 12 series is going to be more comprehensive than ever before, with no less than 4 new models set to be launched. That include two entry level models &#8211; iPhone 12 and iPhone 12 Max &#8211; along with two Pro models &#8211; iPhone 12 Pro and iPhone 12 Pro Max.</p>
<p>Of these, the iPhone 12 Pro and iPhone 12 Pro Max can be considered the successors to the iPhone 11 Pro and iPhone 11 Pro Max while the iPhone 12 Max will be succeeding iPhone 11. The base iPhone 12 is going to be the newest addition to the fall iPhone line-up and will essentially be an iPhone SE but with a more updated build and functionality.</p>
<p>So far as display size is concerned, the iPhone 12 will have a 5.4-inch display while the iPhone 12 Max will have 6.1-inch panel. For the iPhone 12 Pro and iPhone 12 Pro Max, it is going to be 6.1-inch and 6.4-inch respectively.</p>
<p><strong>New design: </strong></p>
<p>The iPhone 12 this time is going to have a fresh new design makeover, which again is going to be distinct than what it was with the iPhone 1,1 which again borrowed design cues heavily from the iPhone X. primary among the changes expected to be introduced with the iPhone 12 include a markedly reduced notch.</p>
<p>According to <a href="https://twitter.com/jon_prosser/status/1252038704060928000"><em>Jon Prosser</em></a> who has been quite vocal with his iPhone 12 revelations this year, Apple will be moving the speaker into the top bezel, thereby making it possible to reduce the bezel size considerably. That apart, iPhone 12 might also mark the return of the flat edge design, something corroborated by YouTuber <a href="https://www.youtube.com/watch?v=ZUXwDpGylpw"><em>EverythingApplePro</em></a> who again got inputs from the usually reliable leaker <em>Max Weinbach</em>.</p>
<p>Another interesting design aspect with the new iPhone 12 is going to be its super compact dimensions. As mentioned by <a href="https://www.youtube.com/watch?v=_oRNdqhoLFc"><em>EverythingApplePro</em></a>, the entry-level iPhone is going to be smaller than the 4.7-inch iPhone SE. That will be achieved with a full-screen display sans the bezel, which means it is going to be practically a 5.4-inch phone as well and will be well suited for one-handed operation.</p>
<p>Meanwhile, there is another school of thought claiming Apple might do with the notch completely this time. Instead, according to a render revealed by <em>Benjamin Geskin</em>, there might be a thin bezel at the top housing the face ID components and other paraphernalia.</p>
<p>As for its construction, it is going to be aluminum for the iPhone 12 and iPhone 12 Max while the iPhone 12 Pro and iPhone 12 Pro Max will have a stainless steel build.</p>
<p><strong>Pro Motion display: </strong></p>
<p>There also rumors of iPhone 12 coming with a Pro Motion display which is Apple&#8217;s way of describing a high refresh rate, to the tune of about 120 Hz. Or maybe it is going to be a display that offers users the option to switch from 60 Hz to 120 Hz refresh rate, something put forth by leaker <a href="https://twitter.com/UniverseIce/status/1152928927037308928?"><em>Ice Universe</em></a>. It’s something that the Samsung Galaxy S20 is already capable of doing.</p>
<p><em>Ice Universe</em> further opined Apple might have started negotiating with Samsung and LG for the said display as well. Unfortunately, there also are rumors of Apple offering the Pro Motion display in only the Pro models with the base iPhone 12 and iPhone 12 Max missing out on the same. Or to make things more drastic, there might be no Pro Motion display on any of the iPhone 12 models at all owing to battery considerations.</p>
<p>In any case, a recent spec leak suggested it is going to be an OLED panel on all of the iPhone 12 models. In contrast, it has been only the iPhone 11 Pro models that featured OLED display while the base iPhone 11 coming with an LCD screen.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="59195061b77030439e3535e96025da7a" data-index="2" style="float: none; margin:0px 0 0px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Inferse Post Middle -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6185183459139085"
     data-ad-slot="8632088704"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p><strong>Apple&#8217;s first 5G phone: </strong></p>
<p>This, no doubt, would be another interesting development given the manner competition already has 5G phones to offer. Not only does this apply to flagship phones but even budget flagship phones or those sitting a rung lower in order too have started to offer 5G feature. Qualcomm’s latest chip offering, the Snapdragon 768G is specially aimed at allowing even mid-range phone to be 5G enabled while offer performance that is a notch lower than that of the flagship SD 865.</p>
<p>However, with Apple&#8217;s own 5G modem nowhere in sight, it did the right thing by mending its ways with Qualcomm. This paved the way for the fitment of Qualcomm&#8217;s 5G modems in the forthcoming iPhone 12 models itself, which otherwise would have taken another year, or two more had Apple stuck with developing its own 5G modem.</p>
<p><strong>Optics:</strong></p>
<p>The iPhone 11 made history by being the first from Apple to have a triple cam set up at the rear. And that was a huge improvement as the picture quality is just amazing. Now, if rumors on this are to be believed, iPhone 12 too will be scripting its own history by becoming the first Apple device to have a quad-cam setup, with there being a LIDAR time-of-flight sensor getting accommodated at the rear this time.</p>
<p>That apart, there also are indications of Apple opting for a periscope like telephoto lens that would be capable of achieving higher zoom. As things stand at the moment, there is a race among the flagships to offer the highest zoom. The Galaxy S20 Ultra offers 4x optical zoom while the Huawei P40 Pro has twin zoom settings of 3x and 10 x optical zoom.</p>
<p><strong>Face ID: </strong></p>
<p>Face ID has evolved as the standard Apple feature for user authentication, replacing Touch ID in the process. However, while it is going to remain the same with iPhone 12 series as well, <a href="https://appleinsider.com/articles/20/04/02/apple-wants-an-iphone-that-doesnt-just-survive-underwater-but-is-usable-there"><em>AppleInsider</em></a> is claiming it is going to have a new sensor with a wider sweep this time to power Face ID. This should allow users to unlock their phone from more extreme angles, like with the phone lying on the table without you having to look at it directly in the face.</p>
<p><strong>USB Type-C port: </strong></p>
<p>This has been one of the long-standing demands from even the most ardent Apple fans. Surprisingly, the company already offers the USB-C ort on the latest iPad Pro devices and it is believed Apple might finally decide to swap its proprietary Lightening port on the iPhone 12 with the USB-C port this time.</p>
<p><strong>Performance: </strong></p>
<p>It is going to be the new A14 Bionic chip powering all iPhone 12 models. Also, the base iPhone 12 and iPhone 12 Max will be having 4 GB of RAM while the two Pro models will have 6 gigs of it. Base storage is going to start at 128 GB and will include a 256 GB model as well for the base iPhone 12 and iPhone 12 Max models. The two Pro models will have an extra version offering 256 GB of storage.</p>
<p><strong>Price: </strong></p>
<p>That is going to start at a quite affordable $649, claims <em>Jon Prosser</em>, which is exactly the reason Apple has chosen to have four iPhone 12 models to offer.</p>
<p>Specifically, the starting prices for each model is expected to be like this:</p>
<p>iPhone 12 128 GB &#8211; $649</p>
<p>iPhone 12 256 GB &#8211; $749</p>
<p>iPhone 12 Max 128 GB &#8211; $749</p>
<p>iPhone 12 Max 256 GB &#8211; $849</p>
<p>iPhone 12 Pro 128 GB &#8211; $999</p>
<p>iPhone 12 Pro 256 GB &#8211; $1,099</p>
<p>iPhone 12 Pro 512 GB &#8211; $1,299</p>
<p>iPhone 12 Pro Max 128 GB &#8211; $1,099</p>
<p>iPhone 12 Pro Max 256 GB &#8211; $1,199</p>
<p>iPhone 12 Pro Max 512 GB &#8211; $1.399</p>
<p><strong>Release date: </strong></p>
<p>That usually happens during the fall season, with Apple launching the iPhone 11 series on September 10 last year. However, things are a lot different his time given the ongoing Covid 19 pandemic the world is reeling under at the moment. If Apple is able to cope with the aftermaths of the pandemic well enough, expect the phone to launch around the first half of September, with a market debut sometime around October. Else, there might be delays if the Covid 9 induced disturbance continues.</p>

<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="59195061b77030439e3535e96025da7a" data-index="3" style="float: none; margin:0px 0 0px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Inferse Post End -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6185183459139085"
     data-ad-slot="6367203234"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div>						</div>

						
						
					
							
		<footer class="postFooter postFooter--single">
							<div class="postFooter-tags">
				<div class="postTags postMeta"><div class="postTags-list"><a class="postTag metaFont" href="https://www.inferse.com/tag/apple/" title="View all posts in Apple" rel="tag">Apple</a><a class="postTag metaFont" href="https://www.inferse.com/tag/iphone/" title="View all posts in iPhone" rel="tag">iPhone</a></div></div>				</div>
			
					</footer>
						
					
				</article>

												
							<div class="relatedPosts relatedPosts--alt">
				<h5 class="blockHeading"><span><i class="fa fa-hand-o-right"></i>You may also like</span></h5>
				
									
											<div class="row">
											<div class="col-xs-12 col-sm-4">
							<article class="postItem post--card post--card--paper post--card--paper--micro post-40645 post type-post status-publish format-standard has-post-thumbnail category-editorials category-smartphones">
		<div class="postFeaturedImg u-ratio2to1 o-imageCropper">
		<img width="400" height="256" src="https://www.inferse.com/wp-content/uploads/2020/05/gaming-400x256.png" class="attachment-md_bone_md size-md_bone_md wp-post-image" alt="" srcset="https://www.inferse.com/wp-content/uploads/2020/05/gaming-400x256.png 400w, https://www.inferse.com/wp-content/uploads/2020/05/gaming-300x192.png 300w, https://www.inferse.com/wp-content/uploads/2020/05/gaming-640x409.png 640w, https://www.inferse.com/wp-content/uploads/2020/05/gaming-768x491.png 768w, https://www.inferse.com/wp-content/uploads/2020/05/gaming-800x512.png 800w, https://www.inferse.com/wp-content/uploads/2020/05/gaming-600x384.png 600w, https://www.inferse.com/wp-content/uploads/2020/05/gaming.png 941w" sizes="(max-width: 400px) 100vw, 400px" />				<a href="https://www.inferse.com/40645/eight-places-where-you-shouldnt-keep-your-phone/" class="o-overlayLink"></a>
	</div>
		<h3 class="postTitle entry-title">
		<a href="https://www.inferse.com/40645/eight-places-where-you-shouldnt-keep-your-phone/" rel="bookmark">Eight places where you shouldn&#8217;t keep your phone</a>
	</h3>
	<div class="metaText metaDate"><abbr class="published updated" title="May 5, 2020">May 5, 2020</abbr></div>
</article>						</div>

											
					
									
											<div class="col-xs-12 col-sm-4">
							<article class="postItem post--card post--card--paper post--card--paper--micro post-56757 post type-post status-publish format-standard has-post-thumbnail category-smartphones tag-apple">
		<div class="postFeaturedImg u-ratio2to1 o-imageCropper">
		<img width="400" height="265" src="https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020-400x265.png" class="attachment-md_bone_md size-md_bone_md wp-post-image" alt="" srcset="https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020-400x265.png 400w, https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020-300x199.png 300w, https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020-640x423.png 640w, https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020-768x508.png 768w, https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020-1360x900.png 1360w, https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020-1000x662.png 1000w, https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020-800x529.png 800w, https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020-600x397.png 600w, https://www.inferse.com/wp-content/uploads/2020/04/iPhone-SE-2020.png 1472w" sizes="(max-width: 400px) 100vw, 400px" />				<a href="https://www.inferse.com/56757/battle-of-the-budget-iphones-iphone-se-2020-vs-iphone-se-2016/" class="o-overlayLink"></a>
	</div>
		<h3 class="postTitle entry-title">
		<a href="https://www.inferse.com/56757/battle-of-the-budget-iphones-iphone-se-2020-vs-iphone-se-2016/" rel="bookmark">Battle of the budget iPhones: iPhone SE 2020 vs iPhone SE 2016</a>
	</h3>
	<div class="metaText metaDate"><abbr class="published updated" title="April 16, 2020">April 16, 2020</abbr></div>
</article>						</div>

											
					
									
											<div class="col-xs-12 col-sm-4">
							<article class="postItem post--card post--card--paper post--card--paper--micro post-56721 post type-post status-publish format-standard has-post-thumbnail category-smartphones tag-xiaomi">
		<div class="postFeaturedImg u-ratio2to1 o-imageCropper">
		<img width="400" height="267" src="https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-400x267.jpg" class="attachment-md_bone_md size-md_bone_md wp-post-image" alt="" srcset="https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-400x267.jpg 400w, https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-300x200.jpg 300w, https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-640x427.jpg 640w, https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-768x512.jpg 768w, https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-1536x1024.jpg 1536w, https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-2048x1366.jpg 2048w, https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-1350x900.jpg 1350w, https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-1000x667.jpg 1000w, https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-800x533.jpg 800w, https://www.inferse.com/wp-content/uploads/2020/03/Redmi-Note-9-scaled-600x400.jpg 600w" sizes="(max-width: 400px) 100vw, 400px" />				<a href="https://www.inferse.com/56721/redmi-note-9-pro-and-note-9-pro-max-launched-in-india-features-indigenous-isro-designed-navic-chip/" class="o-overlayLink"></a>
	</div>
		<h3 class="postTitle entry-title">
		<a href="https://www.inferse.com/56721/redmi-note-9-pro-and-note-9-pro-max-launched-in-india-features-indigenous-isro-designed-navic-chip/" rel="bookmark">Redmi Note 9 pro and Note 9 Pro Max launched in India, features indigenous ISRO designed NavIC chip</a>
	</h3>
	<div class="metaText metaDate"><abbr class="published updated" title="March 12, 2020">March 12, 2020</abbr></div>
</article>						</div>

											
											</div>
					
							</div>
				
				
				
				
<div id="comments" class="comments-area">

			<div class="comments-title blockHeading titleFont">
			<span class="hidden-xs">
				<i class="fa fa-comments"></i>There are no comments yet			</span>
			<span class="hidden-sm hidden-md hidden-lg">
				<i class="fa fa-comments"></i>No comments			</span>
		</div>

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.inferse.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='56881' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="5757f6e855" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="205"/></p></form>	</div><!-- #respond -->
	
</div><!-- .comments-area -->

			</div><!-- end layoutContent-main -->
			
			<aside id="mdSidebar" class="layoutContent-sidebar sidebar sidebar--right js-sticky-sidebar">
				<div class="theiaStickySidebar"><div id="md_posts_list_widget-2" class="widget mdPostsListWidget"><h4 class="widget-title">Recent News</h4>			<ul class="list--micro cardStyle">
										<li>
							<article class="postItem post--card post--card--paper post--card--paper--micro post-56884 post type-post status-publish format-standard has-post-thumbnail category-news tag-amazon tag-fire-7 tag-tablet">
		<div class="postFeaturedImg u-ratio2to1 o-imageCropper">
		<img width="400" height="300" src="https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-400x300.jpg" class="attachment-md_bone_md size-md_bone_md wp-post-image" alt="" srcset="https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-400x300.jpg 400w, https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-300x225.jpg 300w, https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-640x480.jpg 640w, https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-768x576.jpg 768w, https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-1536x1152.jpg 1536w, https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-2048x1536.jpg 2048w, https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-1200x900.jpg 1200w, https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-1000x750.jpg 1000w, https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-800x600.jpg 800w, https://www.inferse.com/wp-content/uploads/2020/05/Amazon-Fire-7-600x450.jpg 600w" sizes="(max-width: 400px) 100vw, 400px" />				<a href="https://www.inferse.com/56884/amazon-fire-7-now-selling-for-just-21-with-case/" class="o-overlayLink"></a>
	</div>
		<h3 class="postTitle entry-title">
		<a href="https://www.inferse.com/56884/amazon-fire-7-now-selling-for-just-21-with-case/" rel="bookmark">Amazon Fire 7 now selling for just $21 with case</a>
	</h3>
	<div class="metaText metaDate"><abbr class="published updated" title="May 18, 2020">12 hours ago</abbr></div>
</article>						</li>
												<li>
							<article class="postItem post--card post--card--paper post--card--paper--micro post-56881 post type-post status-publish format-standard has-post-thumbnail category-smartphones tag-apple tag-iphone">
		<div class="postFeaturedImg u-ratio2to1 o-imageCropper">
		<img width="400" height="255" src="https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-400x255.jpg" class="attachment-md_bone_md size-md_bone_md wp-post-image" alt="" srcset="https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-400x255.jpg 400w, https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-300x191.jpg 300w, https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-640x408.jpg 640w, https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-768x489.jpg 768w, https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-1413x900.jpg 1413w, https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-1000x637.jpg 1000w, https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-800x509.jpg 800w, https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2-600x382.jpg 600w, https://www.inferse.com/wp-content/uploads/2020/05/iPhone-12-2.jpg 1476w" sizes="(max-width: 400px) 100vw, 400px" />				<a href="https://www.inferse.com/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/" class="o-overlayLink"></a>
	</div>
		<h3 class="postTitle entry-title">
		<a href="https://www.inferse.com/56881/apple-iphone-12-series-release-date-specs-what-we-know-so-far/" rel="bookmark">Apple iPhone 12 series release date &#038; specs &#8211; what we know so far</a>
	</h3>
	<div class="metaText metaDate"><abbr class="published updated" title="May 18, 2020">15 hours ago</abbr></div>
</article>						</li>
												<li>
							<article class="postItem post--card post--card--paper post--card--paper--micro post-56877 post type-post status-publish format-standard has-post-thumbnail category-news tag-apple tag-google tag-iphone tag-pixel">
		<div class="postFeaturedImg u-ratio2to1 o-imageCropper">
		<img width="400" height="246" src="https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-400x246.png" class="attachment-md_bone_md size-md_bone_md wp-post-image" alt="" srcset="https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-400x246.png 400w, https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-300x185.png 300w, https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-640x394.png 640w, https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-768x472.png 768w, https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-1536x945.png 1536w, https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-1463x900.png 1463w, https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-1000x615.png 1000w, https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-800x492.png 800w, https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a-600x369.png 600w, https://www.inferse.com/wp-content/uploads/2020/05/Pixel-4a.png 1878w" sizes="(max-width: 400px) 100vw, 400px" />				<a href="https://www.inferse.com/56877/rumored-pixel-4a-with-128-gb-and-349-price-will-be-too-hot-for-the-iphone-se-to-handle/" class="o-overlayLink"></a>
	</div>
		<h3 class="postTitle entry-title">
		<a href="https://www.inferse.com/56877/rumored-pixel-4a-with-128-gb-and-349-price-will-be-too-hot-for-the-iphone-se-to-handle/" rel="bookmark">Rumored Pixel 4a with 128 GB at $349 price could be too hot for the iPhone SE to handle</a>
	</h3>
	<div class="metaText metaDate"><abbr class="published updated" title="May 15, 2020">4 days ago</abbr></div>
</article>						</li>
												<li>
							<article class="postItem post--card post--card--paper post--card--paper--micro post-56874 post type-post status-publish format-standard has-post-thumbnail category-news tag-2019-macbook tag-2020-macbook tag-deal tag-discount tag-macbook">
		<div class="postFeaturedImg u-ratio2to1 o-imageCropper">
		<img width="400" height="270" src="https://www.inferse.com/wp-content/uploads/2020/05/MacBook-Pro-400x270.png" class="attachment-md_bone_md size-md_bone_md wp-post-image" alt="" srcset="https://www.inferse.com/wp-content/uploads/2020/05/MacBook-Pro-400x270.png 400w, https://www.inferse.com/wp-content/uploads/2020/05/MacBook-Pro-300x202.png 300w, https://www.inferse.com/wp-content/uploads/2020/05/MacBook-Pro-640x432.png 640w, https://www.inferse.com/wp-content/uploads/2020/05/MacBook-Pro-768x518.png 768w, https://www.inferse.com/wp-content/uploads/2020/05/MacBook-Pro-1000x675.png 1000w, https://www.inferse.com/wp-content/uploads/2020/05/MacBook-Pro-800x540.png 800w, https://www.inferse.com/wp-content/uploads/2020/05/MacBook-Pro-600x405.png 600w, https://www.inferse.com/wp-content/uploads/2020/05/MacBook-Pro.png 1288w" sizes="(max-width: 400px) 100vw, 400px" />				<a href="https://www.inferse.com/56874/2019-13-inch-and-16-inch-macbook-pro-getting-discounts-of-up-to-300/" class="o-overlayLink"></a>
	</div>
		<h3 class="postTitle entry-title">
		<a href="https://www.inferse.com/56874/2019-13-inch-and-16-inch-macbook-pro-getting-discounts-of-up-to-300/" rel="bookmark">2019 13-inch and 16-inch MacBook Pro getting discounts of up to $300</a>
	</h3>
	<div class="metaText metaDate"><abbr class="published updated" title="May 15, 2020">4 days ago</abbr></div>
</article>						</li>
												<li>
							<article class="postItem post--card post--card--paper post--card--paper--micro post-56867 post type-post status-publish format-standard has-post-thumbnail category-news tag-dell tag-dell-xps tag-macbook-pro">
		<div class="postFeaturedImg u-ratio2to1 o-imageCropper">
		<img width="400" height="225" src="https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17-400x225.jpeg" class="attachment-md_bone_md size-md_bone_md wp-post-image" alt="" srcset="https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17-400x225.jpeg 400w, https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17-300x169.jpeg 300w, https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17-640x360.jpeg 640w, https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17-768x432.jpeg 768w, https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17-1536x864.jpeg 1536w, https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17-1000x563.jpeg 1000w, https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17-800x450.jpeg 800w, https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17-600x338.jpeg 600w, https://www.inferse.com/wp-content/uploads/2020/05/Dell-XPS-17.jpeg 1600w" sizes="(max-width: 400px) 100vw, 400px" />				<a href="https://www.inferse.com/56867/the-new-dell-xps-15-and-xps-17-means-bad-news-for-the-macbook-pro-2020/" class="o-overlayLink"></a>
	</div>
		<h3 class="postTitle entry-title">
		<a href="https://www.inferse.com/56867/the-new-dell-xps-15-and-xps-17-means-bad-news-for-the-macbook-pro-2020/" rel="bookmark">The new Dell XPS 15 and XPS 17 can blow the MacBook Pro 2020 to smithereens</a>
	</h3>
	<div class="metaText metaDate"><abbr class="published updated" title="May 13, 2020">6 days ago</abbr></div>
</article>						</li>
										
			</ul>
		</div>
<!-- Quick Adsense Wordpress Plugin: http://quickadsense.com/ -->
<div id="adswidget1-quick-adsense-3" class="widget widget_adswidget1-quick-adsense"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Inferse Sidebar -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6185183459139085"
     data-ad-slot="6985287277"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>			</aside>

		</div><!-- end layoutContent -->
	</div><!-- end container -->
</main>



		<footer id="footer" class="siteFooter">
						<div class="siteFooter-top">
				<div class="container">
					<nav class="siteFooter-menu navigation navigation--footer">
						<ul id="menu-top-bar-navigation-menu" class="menu"><li id="menu-item-5419" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5419"><a title="About" href="https://www.inferse.com/about/">About</a></li>
<li id="menu-item-5420" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5420"><a title="Contact Us" href="https://www.inferse.com/contact/">Contact</a></li>
<li id="menu-item-5421" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5421"><a title="Team" href="https://www.inferse.com/team/">Team</a></li>
<li id="menu-item-30574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30574"><a href="https://www.inferse.com/terms/">Terms</a></li>
<li id="menu-item-30575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-30575"><a href="https://www.inferse.com/privacy/">Privacy</a></li>
</ul>					</nav>
				</div>
			</div>
			
						
			<div class="siteFooter-bottom">
				<div class="container">
					<div class="siteFooter-bottom-inner clearfix">
						<div class="siteFooter-copyright u-floatLeft metaFont">
							2020 © All Rights Reserved.						</div>
						<div class="siteFooter-backTop u-floatRight">
							<!-- Back top button -->
							<div class="backTopBtn metaFont js-scrolltop-btn">Back to top&nbsp;<i class="fa fa-arrow-up"></i></div>
						</div>
					</div>
				</div>
			</div>
			
		</footer>
	</div>
	<!-- siteWrap -->
	
	<!-- Offcanvas menu -->
	<div id="md_offCanvasMenu" class="md_offCanvasMenu md_offCanvas md_offCanvas--left">
		<div class="offCanvasClose metaFont js-offCanvasClose"><i class="fa fa-times-circle"></i>Close</div>
		<div class="md_offCanvasMenu-social">
					</div>

				<nav class="navigation navigation--offCanvas md_offCanvasMenu-navigation">
			<ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56788"><a href="https://www.inferse.com/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-56790"><a href="https://www.inferse.com/smartphones/">Smartphones</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56784"><a href="https://www.inferse.com/business/">Business</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56786"><a href="https://www.inferse.com/gaming/">Gaming</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56789"><a href="https://www.inferse.com/science/">Science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56787"><a href="https://www.inferse.com/how-to/">How To</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56785"><a href="https://www.inferse.com/editorials/">Editorials</a></li>
</ul>		</nav>
		
			</div>
	
	
	<script type='text/javascript' src='https://www.inferse.com/wp-content/themes/bone/vendors/bootstrap/bootstrap.min.js?ver=3.3.7'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-content/themes/bone/vendors/fotorama/fotorama.js?ver=4.6.4'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-content/themes/bone/vendors/raf-polyfill.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-content/themes/bone/vendors/theia-sticky-sidebar/theia-sticky-sidebar.min.js?ver=1.7.0'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-content/themes/bone/vendors/owl-carousel/owl.carousel.min.js?ver=2.2.1'></script>
<script type='text/javascript'>
WebFontConfig = {
		     	google: {
			    	families: ["Poppins:300,400,700","Arial, Helvetica, sans-serif:300,400,700,300i,400i,700i","'Arial Black', Gadget, sans-serif:300,400,700"]
			    },
			};
</script>
<script type='text/javascript' src='https://www.inferse.com/wp-content/themes/bone/vendors/webfontloader/webfontloader.js?ver=1.6.28'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-content/themes/bone/vendors/zoom/zoom.min.js?ver=0.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mdBoneVar = {"ajaxloadpost":{"ajaxurl":"https:\/\/www.inferse.com\/wp-admin\/admin-ajax.php","failText":"Error loading posts","loadingText":"Loading posts","noMoreText":"No more posts","query_vars":{"p":"56881","page":"","name":"apple-iphone-12-series-release-date-specs-what-we-know-so-far"},"startPage":1,"maxPages":0},"stickySidebar":{"toggle":"1","offsetTop":0},"stickyHeader":{"toggle":"0","hasAdminBar":false},"currentRelURI":"\/56881\/apple-iphone-12-series-release-date-specs-what-we-know-so-far\/","parallaxToggle":"0","highResolution":"","sliderOpts":{"autoplay":false,"timeout":5000}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.inferse.com/wp-content/themes/bone/js/md-scripts.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://www.inferse.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>
<script async="async" type='text/javascript' src='https://www.inferse.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.5'></script>
</body>
</html>